1. Help Center
  2. Troubleshooting

System Requirements

Ziik is developed to use some of the latest features available in web browsers and mobile operating systems. You will therefore need to use one of the following browsers or app versions to use Ziik.

Desktop browsers

safari-chrome-firefox-edge-5ec0087167b5e-1520x800

  • Google Chrome: 78+
  • Mozilla Firefox: 68+
  • Microsoft Edge: 79+
  • Apple Safari: 11+

 

Mobile App

ios-android-icon2

  • Apple iOS: 11+
  •  Android: 6+